Updates from HOPE

* indicates required